Условия, при которых Nano-CMS будет работать.

Требования к серверу:

  1. PHP всё равно в каком подключении (модулем CGI или модулем Апача).
    Мажорная версия - пятая.
    Проверялось на версиях PHP с 5.2 по 5.4

    Собственно Nano-CMS подойдёт любая версия PHP.
    Но её модули будут работать только в пределах версий 5.2-5.4

  2. Модуль mod_rewrite, необходим для работы движка.

  3. Поддержка .htaccess файлов для работы с модреврайтом.

  4. Не заблокированная функция mail(); для работы формы обратной связи.

    Помните:

    Если планируется использование бесплатный хостинг, то учтите, что в большинстве случаев функционал PHP там специально порезан, особенно в части рассылки электронных писем. Чтобы отвадить спамеров.

    Если функция mail(); на хосте заблокирована, писем от формы обратной связи не ждите. Возможно лишь чтение запомненных Наной посланий через админку.

  5. На хосте не должно быть сейфмоды.
    Она не позволит создавать и убивать файлы и папки админкой.
    То есть встроенный редактор Наны может оказаться бесполезным.

    К сейфмоде следует приравнивать также и любые патчи от хостера, ограничивающие возможность создавать и уничтожать директории и файлы силами скрипта. Иногда такое чудо встречается.